Increased response times on data.castoredc.com
Incident Report for Castor
Resolved
The implemented fix has resolved the issue, we're closing this incident report.
Posted May 06, 2021 - 12:23 CEST
Monitoring
We identified the issue and implemented a fix. We'll monitor the situation and update this report in 15 minutes.
Posted May 06, 2021 - 11:59 CEST
Investigating
We are investigating problems with delayed response times on data.castoredc.com, causing the application to become unresponsive for some customers.
Posted May 06, 2021 - 11:25 CEST
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com).