Castor Connect not accessible for some users after upgrade
Incident Report for Castor
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 09:50 CEST
Update
We have confirmed that this fix resolves issues with the 2024.1 release and recommend everyone to update the Castor Connect app to the latest version.

We will continue to actively monitor the situation.
Posted Jul 16, 2024 - 09:08 CEST
Monitoring
We have published a new release of Castor Connect on the Google Play Store which resolves the issue. If you are affected and unable to use the Castor Connect app, please open the Google Play Store and update the Castor Connect app to the latest version (v2024.1.0.1 - 0.2.5) to resolve the issue.

We are currently monitoring the rollout of this new version.
Posted Jul 16, 2024 - 08:54 CEST
Update
We have identified the issue affecting users on Android 14 and are actively working on a fix. Our team is dedicated to resolving this as quickly as possible.

Users can expect a new update by 9:00 AM CET tomorrow.
Posted Jul 15, 2024 - 21:56 CEST
Identified
We have identified that the issue may only be affecting users on Android 14. Users on Apple (iOS) devices and other versions of Android are not impacted.

If you are using Android 14, we recommend that you do not upgrade to the latest version of Castor Connect (2024.1) at this time.

Our team continues to investigate and will provide further updates as soon as possible. Thank you for your patience and understanding.
Posted Jul 15, 2024 - 21:23 CEST
Investigating
We are currently experiencing an issue with the latest version of Castor Connect (2024.1) that is preventing access for a subset of users. Our team is actively investigating the root cause and the impact of this disruption.

We understand the inconvenience this may cause and appreciate your patience as we work to resolve it. We will provide an update on the situation by 21:30 CET at the latest.
Posted Jul 15, 2024 - 20:48 CEST
This incident affected: Castor EDC (🇳🇱 NL Server - data.castoredc.com, 🇬🇧 UK Server - uk.castoredc.com, 🇺🇸 US Server - us.castoredc.com, 🇦🇺 AU Server - au.castoredc.com).