Service disruption on US servers
Incident Report for Castor
Resolved
Service continues to be stable so we are closing this incident. We will take steps to prevent this from happening in the future.
Posted Jun 21, 2022 - 00:33 CEST
Monitoring
We have re-established connection with the US study database and service is operational again. We will monitor the situation before resolving this incident.
Posted Jun 21, 2022 - 00:12 CEST
Identified
We have identified that our US study database server is currently unavailable. We are working on a solution and will keep posting status updates here.
Posted Jun 20, 2022 - 22:59 CEST
Investigating
We are currently investigating an issue which causes disruption on our US services.
Posted Jun 20, 2022 - 22:44 CEST
This incident affected: Castor eConsent (🇺🇸 US Server - us.castorconsent.com) and Castor EDC (🇺🇸 US Server - us.castoredc.com).